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Figure 1. GISSMO GUI; main window 

 

1 Create a project 
In this section, we see the process of fitting an initial spin matrix of Alanine (C3 H7 N O2). 
The corresponding BMRB ID for this compound is bmse000028. In general, the initial spin 
matrix can be generated using NMRdb, Gaussian, MNova, or manually from scratch. For this 
example, we create it manually. The optimized spin matrix for the compound can be found 
from GISSMO’s website [http://gissmo.nmrfam.wisc.edu/]. 
In the spin matrix shown in the GUI, the diagonal cells indicate the chemical shifts of the 
spins (PPM) and the off-diagonals indicate coupling constants in Hz. 

 
To create a project, we need some information about the compound of interest.  

I. We start from a 3D representation of the compound (3D structure file in “.mol” or 
“.sdf” formats). For the current example, we can download the structure file from 
BMRB [link]. This file is names “3343.mol”. 

II. We also need an experimental spectrum for the compound that could be 
downloaded from BMRB too. If you scroll down the BMRB page, you will see a 
spectrum that corresponds to the 1D-1H experiment, with concentration of 100 mM, 
temperature 298K, and pH of 7.4. the hyperlink below the figure (1H.tar) links to a 
compressed file containing the experimental data. For this example, you can click on 
here to download the file. When downloaded, you should extract the file.  

http://www.bmrb.wisc.edu/metabolomics/mol_summary/show_data.php?id=bmse000028&whichTab=1
http://gissmo.nmrfam.wisc.edu/
http://www.bmrb.wisc.edu/ftp/pub/bmrb/metabolomics/standards/L_alanine/lit/3343.mol
http://www.bmrb.wisc.edu/metabolomics/standards/L_alanine/nmr/bmse000028/1H.tar


 6 

III. We next retrieve unique atom labels from the ALATIS server 
(http://alatis.nmrfam.wisc.edu/). Upload the downloaded mol file from BMRB 
(3343.mol) to the webserver. It will take a couple of seconds to generate the unique 
atom names [here]. From ALATIS output it is clear that we will have 4 spins in our 
spin matrix; there is a methyl group (H7, H8 H9) and a single proton attached to C2 
(H10). When we do not create the spin matrix from scratch, we need to have the 
correspondence map between the input and output structure files, which can be 
downloaded from the link on the ALATIS result page. “Correspondence map between 
input and unique labels (download)”.  

IV. [Optional] To generate a 2D figure, we need to download ALATIS output (modified 
mol file (download)). The output file is named “alatis_output_bmse000028.mol”. 
Then use the GISSMO website 
[http://gissmo.nmrfam.wisc.edu/static/convert_mol_svg.html] to convert the 3D 
structure file to a 2D figure. This website provides two image files in the SVG and JPG 
formats. Since the GISSMO accepts JPG file formats, make sure you download the 
second 2D image from the website. 

V. [Optional] Additional information from ALATIS is needed. We can use the reported 
InChI strings from ALATIS website. 

VI. Run GISSSMO. 
- From ‘File’->‘Create a project’. You will see Figure 2a. 

 

  
(a) Initial window (b) Filled 

Figure 2. Create a project. 

 
- I chose “alanine_gissmo” as the compound name 
- Copy/pasted the InChI string from the ALATIS website to its corresponding box on 
the GUI. 

http://alatis.nmrfam.wisc.edu/
http://alatis.nmrfam.wisc.edu/examples/BMRB/bmse000028/
http://alatis.nmrfam.wisc.edu/examples/BMRB/bmse000028/map.txt
http://alatis.nmrfam.wisc.edu/examples/BMRB/bmse000028/alatis_output_bmse000028.mol
http://gissmo.nmrfam.wisc.edu/static/convert_mol_svg.html
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- Loaded the 2D figure “gissmo.jpg” that we made using GISSMO’s website. 
- To create the spin matrix, click on the ‘Explore options’. Set the parameters as 
shown in Figure 3; set the type to ‘Create empty’ and number of spins to 4. This is 
because we saw from the structure that there are 4 spins in the molecule. Then click 
on ‘Done’. 
 

 
Figure 3. Create an empty spin matrix with 4 spins.  

 
- To load the experimental data, be sure you followed (II); download the compressed 
file for the 1D-1H spectrum and extract it. Then click on ‘Explore options’. You will 
see Figure 4. Set the file type to ‘Bruker’ and the default is 1D-1H, which is fine. The 
‘hint’ section will explain which files the GUI expects to see in the folder you select. 
Click on the ‘Select a folder’ and browse to the extracted 1H folder.  
 

 
Figure 4. Load experimental data. 

 
- Choose the output folder, where the GUI should populate the project files. 
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We should see the main window with all of the parameters are set (Figure 2b). 
- Press ‘Create’. You will see a message box that tells you the project has been saved. 
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2 Open 
2.1 Open a project 

From ‘File’ -> ‘open a project’, browse to the folder you saved the project and open 
‘spin_simulation.xml’. The GUI will automatically update to Figure 5. 

 
Figure 5. Open a project file. 

 
You will see the experimental data on the top spectrum. The atoms in the spin matrix are 
labeled 1 to 4, and the button-left spectrum is empty. In the following sections we discuss 
the possible options and fitting the spin matrix. 
 

2.2 Open a database 
A database is a folder that contains multiple saved projects in it. For example, the project 
that we have created is a single project and if you browse to the folder, it should contain a 
folder named ‘1H’, ‘mol_2d.jpg’, and the ‘spin_simulation.xml’. A database contains multiple 
folders that contain these files. For example, our BMRB database is a folder that contains 
several hundreds of sub-folders. In Figure 6 the top 5 sub-folders of the database folder are 
shown. Every sub-folder contains 3 items; experimental spectrum (1H), 2D image 
(bmse00000x.jpg), project file (spin_simulation.xml). When the folder containing these sub-
folders is selected, the GUI will show a drop-down menu that lists different projects. Users 
can select a project and press the ‘load’ button next to the drop-down to load a project file. 
(Figure 7).  
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Figure 6. A screenshot of subfolders in a database folder.  

 
 

 
Figure 7. Open a database.  
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3 General features of the GUI 
Let us load the ‘alanine_gissmo’ project. We should see Figure 5.  

3.1 Mouse-wheel functions 
If we click on the experimental spectrum (top spectrum), and use mouse-wheel, we can scale 
the spectrum to see the DSS peak at 0 PPM. The scaled spectrum is shown in Figure 8. The 
same functionality of mouse-wheel exists for the superposition of the simulated and 
experimental spectra (bottom-left spectrum). 
 

 
Figure 8. Mouse-wheel functions. 

 
3.2 Zoom in/out, pan, and data-tip button 

The magnifier icons on the top of the GUI can be used to zoom in/out on a spectrum. You 
can select one of these icons and draw a box on the spectra (either experimental or 
superposition). By selecting the pan button, you can navigate on the spectra and move a 
spectrum to the left/right. By selecting the data-tooltip button you can select a point on a 
spectrum and it will report the corresponding chemical shift and amplitude of the point. In 
Figure 9, I used the ‘+’ magnifier and zoomed around 3.5-4 PPM. I chose the data-tooltip to 
get PPM and amplitude of one of the peaks. Note that the ‘Mouse-wheel’ scaling function 
will be disabled by selecting any of these buttons. When you de-select these buttons, the 
mouse-wheel function for scaling the spectra will be activated again. 
 

 
Figure 9. data-tooltip. 
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3.3 ‘Draw full experimental spectrum’ 
After using the buttons described above, you can use this button on the GUI for a quick 
refocusing the experimental spectrum to the full view. 
 

3.4 Note window 
We can use the Note window (‘Tools’->’Note’) to change status of the project and also add 
notes to the project. The status and the notes will be saved when the workspace is being 
saved. Figure 10 shows the predefined project status.  
 

 
Figure 10. Note window. 

 
 
3.5 Show 2D figure 

This button can be used to show the 2D figure we downloaded from the GISSMO website 
(gissmo.jpg) and loaded when creating the project file. Figure 11 shows an example. 
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Figure 11. Show 2D plot button. 

 
3.6 Draw InChI strings 

From ‘Tools’ -> ‘Auxiliary tools’ -> ‘Drawing tools’ -> ‘Draw InChI string graph’. This option 
opens a window that shows the InChI string that we provided when creating the project. The 
edit box is editable, so you can replace the string with other InChI strings. By pressing the 
‘Draw’ button, the GUI will generate a graph representation of the InChI string. This graph 
will be used when we process the spin matrix.  
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Figure 12. Draw InChI strings as graphs. 

 
3.7 Show a molecule 

From ‘Tools’ -> ‘Auxiliary tools’ -> ‘Drawing tools’ -> ‘Show a molecule’. The way that this 
option works is that, it will generate a html file that uses jsmol to draw your molecule. After 
pressing the ‘Show a molecule’ button, it will open a browse window to select your structure 
file. For our example, the mol file was downloaded from ALATIS 
(alatis_output_bmse000028.mol).   
 

 
Figure 13. Show a molecule using jsmol. 
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4 Processing a project 
4.1 Adjust spin names 

When one of the acceptable software packages (nmrDB, Gaussian, MNova) are used to 
create the initial spin matrix, we need to use the correspondence map from ALATIS to 
rename the spins. For our example, that we started from scratch, we can use the 2D figure 
to rename the atom names. From the main GUI, click on ‘Show 2D figure’ button to see the 
2D representation of the molecule. From the main GUI, ‘Tools’ -> ‘Rename atoms’. We 
should have the windows in Figure 14a opened. 
 

  
(a) (b) 

Figure 14. Rename atoms  

 
Since we are starting from an empty spin matrix, we can freely assign the spins to the atoms 
in the 2D figure. I am going to assign spins 1, 2, 3 (current name) to the methyl group and 
rename them to protons 7, 8, and 9. Therefore, the spin 4 will be assigned to proton 10. 
Figure 14b shows the window after entering the unique atom labels. By applying the 
updates, the spin names in the main GUI will be updated. 
 
 

4.2 Initialize spin matrix 
4.2.1 Initialize chemical shift values 

Since we have started from an empty spin matrix, we need to initialize the spin matrix. For 
this process, we start with assigning initial chemical shifts. From Figure 8, it is clear that 
spins lay in the region 1 to 4 PPM. Figure 15 shows this region on the experimental 
spectrum.  
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Figure 15. Experimental spectrum for initializing the spin matrix 

 
We need the integral of these peaks to initialize the chemical shifts of the spins. To get 
these values, press the ‘get ROI from exp. spectrum’ button to adjust the domain. You will 
see that the ROI range will be updated. Figure 16 shows this range and the superposition 
spectrum. The red-line shows the simulated spectrum and the blue line shows the 
experimental spectrum in the ROI. We note that since the spin matrix is empty, the 
simulated spectrum looks irrelevant.   
 

 
Figure 16. ROI for initializing the spin matrix 

 
Use ‘Tools’ -> ‘Auxiliary tools’ -> ‘Get spectral info’. This option will change your cursor 
mode and waits until you draw a box on the experimental spectrum. Let us start with the 
doublet close to 1.5 PPM. It will open a window that contains the experimental spectrum 
in the range that you draw the box. It is shown in Figure 17a. The first thing to notice is that 
the integral of the region is about 3, which indicates this region represents 3 spins; namely 
the protons in the methyl group. Next, I will use data-tooltip to select the two peaks of the 
doublet. After selecting these two peaks and pressing ‘Process selected …’ the GUI will 
generate Figure 17b. Which basically is telling us the protons are located at 1.466 PPM. So 
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I am going to update the chemical shift value (diagonal cells) of these protons on the spin 
matrix.  
 

  
(a) (b) 

Figure 17. Get spectral info; doublet 

 
Next, I am going to use ‘Tools’ -> ‘Auxiliary tools’ -> ‘Get spectral info’ to get chemical shift 
of the proton 10 as shown in Figure 18. The integral is about 1 that indicates there is one 
spin in this region, as expected. The center of the quartet is at 3.768 PPM that represents 
the chemical shift of proton 10. 
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Figure 18. Get spectral info; quartet.  

 
Updated spin matrix is shown in Figure 19. By pressing the ‘Process’ button on the GUI we 
get a simulated spectrum and the ‘Normalized RMSD’ will change from 0.38 to 0.10. 
 

 
Figure 19. Updated spin matrix with approximate chemical shifts 

 
4.2.2 Initialize coupling constants 

We use ‘-16’ Hz as the coupling constants between protons (2JHH) attached to the same 
heavy atoms (geminal couplings), and ‘7’ Hz for vicinal couplings (3JHH). Then the initial spin 
matrix and its corresponding simulated spectrum change to Figure 20.  
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Figure 20. Initialized spin matrix 

 
To get the full view of the superposition spectra, we can use ‘Draw full experimental 
spectrum’ and then press ‘get ROI from exp. spectrum’. This will adjust the region to show 
the spectrum, and by using the ‘Process’ button, we can see the entire simulated and 
experimental spectra. The cyan zigzag lines show the regions that are removed as water 
and DSS regions (Figure 21). 
 

 
Figure 21. Superposition of the simulated and experimental spectra; initial 
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4.3 Optimization tools 
4.3.1 Grained optimization on chemical shifts 

To see the procedure for using this option, we are going to try it on spin 10.  
- Select the corresponding cell on the spin matrix 

 

 
Figure 22. Select a chemical shift cell for the grained optimization. 

 
- Use ‘Tools’ -> ‘Optimization’ -> ‘Optimize chemical shift (grained)’. The window that 

is shown in Figure 23 shows up and asks for a domain in which you want to optimize 
the chemical shift value. Defining this domain will become practical, when there are 
spins close to each other and you want to optimize the chemical shift of one of them. 
By default, the range is defined based on the current chemical shift of the spin (3.7680 
PPM) +/- 0.03 PPM. If need be, you can change this range. 
 

 
Figure 23. Grained CS optimization; domain 

 
After pressing ‘Apply’, the GUI performs a restricted optimization on the provided 
domain. We note that since the spin matrix has just been initialized and coupling 
constants and other chemical shifts may not be correct, the output of this 
optimization may not be exactly right. When the process is done, you can see the 
chemical shift of the spin 10 has changed to 3.7677. After clicking on ‘Process’, the 
normalized RMSD has changed from 0.03318 to 0.03188. There is not a big difference 
between the RMSD values, owing to the fact that the spins are distributed nicely and 
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there is no peak overlap, etc. Hence during our initialization process we got a good 
estimate for the chemical shifts. 
 

4.3.2 Optimization over groups of cells from a spin matrix 
This option is considered to optimize a set of cells that we know they should be assigned 
to the exact same value. For example, we want the chemical shift values of the methyl 
group (spins 7, 8, 9) be the same, or the couplings between these spins should be the 
same. To try this option, select the chemical shifts of these spins. You can do this by 
selecting one of them and then keep ‘Ctrl’ button from your keyboard down.  
 

 
Figure 24. Optimization over groups; selecting 3 cells from the spin matrix 

 
Then use ‘Tools’ -> ‘Optimization’ -> ‘optimization over groups of cells’. This will open a 
window that contains the selected cells and asks you to group the cells (Figure 25). The 
first column in this window shows the corresponding spin labels of the selected cells. For 
example, 7-7 means the cell between spin 7 (row) and spins 7 (column). In general, we 
have the option to group cells in multiple groups (for example, if I have selected these 
chemical shifts and the coupling constants between them, I could group the chemical 
shifts into one group and all of the coupling constants into another group). For the current 
example, we can check the box (Group all cells in one group) so the GUI automatically 
groups all of the cells into ‘Group(1)’. Otherwise, we can use the dropdowns in the ‘group 
id’ column to decide and group the cells manually.  
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Figure 25. Optimization over groups; grouping cells 

 
After grouping the selected cells, the GUI will perform an optimization process on the 
cells. A progress bar will show the status of the optimization. When it is done, the cells 
will automatically be updated. In our example, the chemical shift values have changed 
from 1.4660 to 1.4662 PPM. Again, because I chose a nice example, these optimizations 
won’t change the values much. After processing the spin-matrix (‘Process’ button), we 
will see the effects of the optimization on the simulated spectrum. For me, it changed the 
RMSD from 0.03191 to 0.03168 (Figure 26).  
 

 
Figure 26. Optimization over groups; output 

 
 

4.3.3 Optimizations on chemical shifts and coupling constants 
When we want to optimize some cells but don’t need to group them, i.e. there is no need 
to have the same values for the cells, then we use this option. After selecting the cells 
from the spin matrix, we can either use ‘Tools’ -> ‘Optimization’ -> ‘Optimization over 
selected cells’ or we can simply press the ‘Optimization’ button on the main GUI.  
To see an example of this feature, I will optimize the chemical shift of spin 10 and the 
coupling constant between spins 10 and 9. We note that, the couplings between spin 10 
and the methyl group should be the same, but for this example we optimize the coupling 
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between spins 10 and 9. At the end of this section I will group optimize the couplings 
between spin 10 and the methyl group.  
So, for now, select the chemical shift of spin 10 and its coupling to spin 9 (Figure 27). Then 
press the ‘Optimization’ button as pointed in the figure.  
 

 
Figure 27. Optimization over selected cells; select two cells 

 
When optimization is done, it will automatically update the spin matrix. As you can see, 
the selected cells have changed 3.7677->3.7672 and 7->7.2055. By processing this spin 
matrix, the RMSD will change from 0.03168 to 0.03071. 
As mentioned before, we want the coupling constants between spin 10 and the methyl 
group be the same. So I am going to select their corresponding cells (Figure 28) and follow 
the instruction for optimization over groups of cells (4.3.2).  
 

 
Figure 28. Group optimization over couplings of spin 10 
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This will change the coupling constants to 7.0788 Hz and the RMSD from 0.03071 to 
0.03115. Increments in the RMSD value tell us the values most probably are not correct 
and we need more adjustments on the spin matrix. We next consider the couplings 
between the methyl group that should be the same. Hence, we repeat the group 
optimization on these cells (Figure 29).  
 

 
Figure 29. Group optimization on methyl group CC 

 
The group optimization (4.3.2) resulted in changing the coupling constants to -16.3941 
and RMSD changed to 0.03113. Insignificant changes, but we want to try different 
modules of the GUI on a nice system.  
 

4.3.4 Optimization on line shape parameters 
By default, the line shape parameters (line width, Lorentzian and Gaussian coefficients) are 
set to line width of 0.3, 20% contribution from the Gaussian line shape function and 80% 
contribution from the Lorentzian line shape. These values may change for different spin 
matrices, experimental spectrum, etc. Hence, we keep optimizing the line shape 
parameters. To do so, use ‘Tools’ -> ‘Optimization’ -> ‘Optimize line shape’. It will ask you 
to choose a domain for the optimization process (Figure 30). You can choose the entire 
spectrum, in which the RMSD is calculated from the entire PPM domain, or do optimization 
on a specific domain (ROI: region of interest).  
 

 
Figure 30. Line shape optimization; domain 
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I would recommend to optimize the line shape parameters on an ROI when you are working 
on isolated spins, and use the entire frequency domain otherwise. In our case, the 
Lorentzian coefficient will change to 0.142 (14.2%) and the Gaussian coefficient changes to 
85.8%. Processing the workspace will update the RMSD value that now has changed to 
0.00677. 
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5 Finalizing the project 
Before generating outputs, I like to reconsider the couplings between spin 10 and the 
methyl protons. I will do a group optimization on these coupling constants (4.3.2). Last time 
that we tried it, it increased the RMSD. Figure 31 shows the output after group optimizing 
these cells. As indicated in the figure, the coupling constants increased to 7.2926 Hz and 
the RMSD reduced to 0.00476. We note that these changes might seem insignificant, but 
we are trying different modules of the GUI. 
 

 
Figure 31. Group optimization on couplings of spin 10. 

 
Now, that the spin matrix is indeed a good ideographic representation of the experimental 
spectrum, we want to export the results. Before doing so, I am going to add notes to the 
workspace. Use ‘Tools’ -> ‘Notes’ to adjust status of the project to ‘Done’. We can also add 
some notes to it (Figure 32).  
 

 
Figure 32. Adding notes to a completed project 
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5.1 XML format 
From the ‘File’ -> ‘Save workspace’ we can export the workspace as xml format. This format 
is readable by the GISSMO GUI and since it is structured, other scripts can be developed to 
parse the files. 
 

5.2 HTML format 
Exporting a workspace as html file is similar to the XML format (‘File’ -> ‘Save workspace’). 
Any web-browser can read these html files and we designed it such that the outputs are 
human readable. The output html of this example is shown Figure 33. 
 

 
Figure 33. output html file. 

 
5.3 Export simulated spectrum in csv format 

Use ‘file’ -> ‘Save spectra’ -> ‘Simulated spectrum (csv)’. This opens a window so you can 
browse and create a file to save the simulated spectrum. The output file will have two 
columns that are separated by a ‘,’; the first column shows frequency (PPM) and the second 
column shows the amplitude at its corresponding PPM. 
 

5.4 Export simulated spectrum as a figure 
Use ‘file’ -> ‘Save spectra’ -> ‘Simulated spectrum (figure)’. This will open a MATLAB figure 
that shows the simulated spectrum. You can save this figure in many different formats 
including ‘JPG’, ‘TIFF’, ‘EPS’. Figure 34 shows our simulated spectrum. 
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Figure 34. Export simulated spectrum as a figure. 

 
5.5 Export superimposed spectra as a figure 

We can also export the superimposed figures. By using the ‘file’ -> ‘Save spectra’ -> 
‘Superimposed spectra (figure)’, the GUI will open a window for adjusting frequency and 
amplitude offsets. It is worth noting that this window shows the domain shown in the 
bottom-left superimposed spectra. In Figure 35 I magnified into the region of 1 to 4 PPM and 
then exported the superimposed figure. By default, the offset values are set to zero, but you 
can change any of them and the ‘draw’ button will show the output. In Figure 35 I used a 
vertical offset of ‘.1’. 
 

 
Figure 35. Adjusting offsets for the superimposed spectra 
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By pressing the ‘export’ button, the window will use the offset values to generate a MATLAB 
figure that can be saved in many different formats (Figure 36).  
 

 
Figure 36. Exporting superimposed spectra 
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6 Splitting a spin matrix 
To see this feature of the GUI, we use DSS (C6 H15 O3 Na Si S) as an example. Create a 
project (Section 1.Create a project) for the BMRB compound bmse000795. You can 
download the structure file from BMRB, and ALATIS outputs (see webpage). From Figure 
37, it is clear that there are 3 methylene groups (6 spins) and three methyl groups (9 spins). 
Therefore, there are 15 spins in the compound. 
 

 
Figure 37. 2D projection of DSS. 

 
After creating a project, the GUI should look like Figure 38. 
 

 
Figure 38. Creating DSS project 

 

http://bmrb.wisc.edu/metabolomics/mol_summary/show_data.php?id=bmse000795&whichTab=1
http://alatis.nmrfam.wisc.edu/examples/BMRB/bmse000795/
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I am going to rename the spins from spin 1 replaced with proton 12 to spin 15 to be 
replaced with proton 26 (Figure 39).  
 

 
Figure 39. Renaming DSS spins 

 
Before continuing with the process of initializing the spin matrix, with need to un-check the 
‘delete DSS region’ from the main window (Figure 40). 
 

 
Figure 40. Do not delete DSS region 

 
It is clear that the 9 methyl protons are located at 0 PPM and the two triplets belong to 
methylene’s at C6 and C5 (we don’t know which one is which), and the triplet that has extra 
smaller peaks (results of couplings) belong to the methylene at C4 that its protons have 
couplings to the protons of the other methylene’s.  
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Methyls H21 and H22 

  
H25 and H26 H23 and H24 

Figure 41. Initial CS assignment for DSS 

 
I will adjust the chemical shifts based on the assignments in Figure 41. 
Since there are more than 10 spins, as discussed in the paper, it is preferred to split the 
spin matrix into smaller sub-matrices. For this example, I am going to make 2 sub-matrices 
as shown in Figure 42; the methylene protons in one group and methyl protons in another 
group. 
 

 
Figure 42. Splitting plan 
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6.1.1 Split a spin matrix 

Use ‘Tools’ -> ‘Splitting spin matrix options’ -> ‘Split spin matrix’. After splitting a spin 
matrix, we don’t have the option to rename atoms, which is ok since we have done it 
already.  
It will ask us the number of sub matrices that we want to make (Figure 43a), which in our 
case is 2. Then a window will appear that shows spin names in the first column and a 
dropdown for every spin that you can assign the spin to a sub matrix (Figure 43b). If we 
follow the splitting plan in Figure 42, we should have (Figure 43c). 
 

 
(a) 

  
(b) (c) 

Figure 43. Splitting DSS spin matrix 

 
Then press ‘Split’. A window will appear that shows the spin matrices; sub matrix (0) is 
the original spin matrix with 15 spins, sub matrices 1 and 2 show the list of their 
constituent atoms. You can close this windows and if needed you can open it using ‘Tools’ 
-> ‘Splitting spin matrix options’ -> ‘Show sub matrices’. 
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6.1.2 Process a sub-matrix 
Now that we split the spin matrix, we can process them individually. Use ‘Tools’ -> 
‘Splitting spin matrix options’ -> ‘Process a sub matrix’. It will open a dialogue box to 
choose which sub-matrix we want to process (Figure 44).  
 
 

 
Figure 44. Process a sub-matrix; choose one 

  
 We choose sub matrix 1 that has 9 spins from the methyl groups. Their chemical shift 

values should be 0, which is the default value. We next initialize the coupling constants. 
The coupling constants between protons of every methyl group will be set to -16 (Figure 
45).   

 

 
Figure 45. Init sub matrix 1 

  
 Press ‘Process’ and remember the ‘delete DSS region’ should be un-checked. Now, if we 

zoom into the superimposed spectra about 0 PPM, we will see Figure 46. The red line is 
the simulated spectrum and the blue line shows the experimental spectrum from BMRB. 
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Figure 46. DSS about 0 PPM. 

 
 Now, a group optimization on the coupling constants to have even a better fit (Figure 47).  
 

 
Figure 47. Processing sub-matrix 1; group optimization on coupling constants 

  
 After optimization is done, the coupling constants will change to -16.4016.  
 We next process the other sub matrix.  From ‘Tools’ -> ‘Splitting spin matrix options’ -> 

‘Process a sub matrix’ select the sub matrix 2. To adjust the chemical shifts, we zoom into 
the experimental spectrum and use the data-tooltip to get the PPM for the spins 21 and 
22 (Figure 48). We follow Figure 41 and use the data-tooltip to set the initial chemical 
shifts for other protons in the spin matrix. 
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Figure 48. Data-tooltip to get CS. 

  
We next initialize the coupling constants; between methylene protons -16 Hz and the 
vicinal couplings to 7 Hz. The initialized spin matrix will look like Figure 49. 
 

 
Figure 49. Init sub matrix 2 

 
Process the sub matrix to get the superimposed spectra; it is clear that we need more 
adjustments to get a better fit.  
- Optimize couplings between spins 23-24. 
- Optimize couplings between spins 25-26. 
- Optimize line shape parameters 
- Use section 8. ABX/ABXY Optimizations for ABxy optimization 
- Uncheck the ‘delete DSS region’ and process. 
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6.1.3 Merging sub-matrices 
To merge the processed sub-matrices, we can use ‘Tools’ -> ‘Split spin matrix options’ -> 
‘Merge sub matrices’. It will open a window (shown in Figure 50) that, if needed, you can 
scale the simulated spectra for each of the sub matrices before merging them. This is not 
the case here, so we use the default scaling factors (1) and merge the sub matrices. The 
spin matrix on the main GUI should show all of the 15 spins.  
 

 
Figure 50. Merge sub-matrices. 

 
We can use the ‘Process’ button to see the merged simulated spectra over the 
experimental data. When the sub-matrices are merged, ‘Process’ button does not process 
the spectra (which is time consuming) and only shows the superimposed merged spectra 
(Figure 51). 
 

 
Figure 51. Superimposed merged spectra 

 
We can change status of the project and export it as described in “Section 5. Finalizing the 
project”.  
 



 38 

6.1.4 Delete sub-matrices 
Sometimes it is needed to delete sub-matrices, mainly due creating them by mistake and 
when we want to split the spin matrix in a different way. This option is considered under 
‘Tools’ -> ‘Splitting spin matrix options’ -> ‘Delete sub matrices’, which will delete every 
information about all of the sub matrices.   
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7 Additional couplings 
For this section we see fitting of D-(-)-3-phosphoglyceric acid (C3 H7 O7 P), from BMRB entry 
bmse000007. We can get the BMRB structure file and its corresponding unique atom labels 
from ALATIS website (here). We use the GISSMO website to generate a 2D representative of 
the compound (Figure 52).  
 

 
Figure 52. D-(-)-3-phosphoglyceric acid 

 
From the structure file it is clear that we have 3 spins in the compound. So we create the 
spin matrix with 3 spins. We can pull out the initial chemical shift values using the ‘Tools’ -> 
‘Auxiliary tools’ -> ‘Get spectral info’ (Figure 53).  
 
 
 
 
 
 
 
 

http://alatis.nmrfam.wisc.edu/examples/BMRB/bmse000007/
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Figure 53. Analyze experimental spectrum for initialization 

 
I updated spin names and assigned 4.176 to spin 14, and 4.016 and 3.866 to the methylene 
group. Set the geminal coupling to -16 and vicinal couplings to 7 Hz. The initialized spin matrix 
looks like Figure 54. 
 

 
Figure 54. Additional coupling; initial spin matrix 
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We use the ABX optimization (follow 8.ABX/ABXY Optimizations) and set the optimization 
window as shown in Figure 55; spins 12 and 13 are AB and spin 14 is the X.  
 

 
Figure 55. Setting up ABX optimization 

 
The output of optimization reduces the RMSD and there is a better fit, however, the AB spins 
are off (Figure 56). This is because there is a 3JPH effect on the methylene protons. 
 

 
Figure 56. Output of ABX optimization. 

 
 

7.1.1 Apply additional couplings 
Since we don’t consider 31P in a proton spin matrix, we need to consider additional 
couplings for our spin matrix. Use ‘Tools’ -> ‘Additional coupling constants’ -> ‘Apply 
additional coupling constants’. This will open a window that asks you how many 
additional couplings you want to add and how many groups of spins you want to consider. 
For our example, there are two groups of spins (we don’t necessarily know spins 12 and 
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13 will have the same couplings to the atom P11) and 2 coupling constants, as shown in 
Figure 57. Press ‘create’ to create the necessary table. Label spins 12 and 13 (we do not 
want to apply additional couplings to spin 14), and initialize the additional couplings with 
7 Hz. 
 

 
Figure 57. Set up additional couplings 

 
If we process the spin matrix, the simulated spectrum contains the necessary peaks, but 
they need more adjustment (Figure 58). 
 

 
Figure 58. Initialized additional couplings; simulated spectrum 
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7.1.2 Edit additional couplings 
We can manually adjust the additional couplings. To do so, use ‘Tools’ -> ‘Apply additional 
couplings’ -> ‘Edit additional couplings’. It will open a window that you can edit the 
coupling constants (Figure 59). We don’t use this feature for the current example. 
 

 
Figure 59. Manual adjustment of additional couplings 

 
7.1.3 Label additional couplings 

This option is considered to automatically update the spin matrix, when the additional 
coupling is between two spins (when we split the spin matrix, and there are couplings 
between the spins from two different sub-matrices). In this example, since the additional 
coupling is coming from the 31P, we won’t label the additional couplings.  
 

 
Figure 60. Labeling additional couplings 
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7.1.4 Remove additional couplings 
There is an option to remove the additional couplings under the ‘Tools’ -> ‘Apply 
additional couplings’ that will remove all additional couplings. 
 

7.1.5 Optimizing additional couplings 
For the current example, we need to optimize additional couplings (in addition to apply more 
adjustments on the spin matrix).  
Since the simulated peaks for spin 13 seem off, I am going to optimize this chemical shift. I 
can either use the 4.3.1. Grained optimization on chemical shifts, or just select the 
corresponding cell and press the ‘Optimize’ button from the main GUI (Figure 61).  
 

 
Figure 61. Optimizing CS 

 
Do the same for spin 12, and also optimize the line shape parameters. The optimization 
processes adjust the chemical shift and reduces the RMSD value. To adjust the coupling 
constants, after adding the couplings from P11, we use the ABX optimization again. 
So the spin matrix is ready to optimize the additional couplings; use ‘Tools’ -> ‘Optimization’ 
-> ‘Optimize additional couplings’. It will open a window (Figure 62) that asks which 
additional couplings you want to optimize. In our example, both of them.  
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Figure 62. Additional couplings; optimization 

 
 
The output of these optimizations fit very well with the experimental spectrum (Figure 63). 
You can see the additional couplings values using ‘Tools’ -> ‘Additional coupling constants’  -
> ‘View additional coupling constant’ (Figure 64)  
 

 
Figure 63. Additional couplings; Output of optimizations 
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Figure 64. View additional coupling constants. 

 
I am going to change the status of the project and export it. As indicated in Figure 65, the 
html report shows the additional couplings assigned to the spin matrix.  
 

 
Figure 65. Export to HTML of additional couplings 
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8 ABX/ABXY Optimizations 
Use ‘Tools’ -> ‘Optimization’ -> ‘Guided optimization’ -> ‘ABX/ABXY optimization’. This will 
open a window that asks you to choose the AB and XY spins. For the example in the submatrix 
2 of DSS, we will choose spins 21 and 22 as the AB, and spins 23 and 24 as the XY spins (Figure 
66a). After optimizing the coupling constants and chemical shifts, we repeat the process with 
spins 25 and 26 (Figure 66b) 
 
 

  
(a) (b) 

Figure 66. ABXY optimization window 
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